Infrastucture problems
Incident Report for Trinsic
Postmortem

We deployed a release to production that was intended for our staging environment. The safeguards we have in place to prevent these issues did mot prevent this mistake. The release caused an issue which was caught within a few minutes, but the changes took about 30 minutes to reverse. To prevent this from happening in the future, we've isolated our staging and production environments further to prevent confusion. We're also requiring additional approvals on production releases. We apologize for the interruption and are committed to continuing to provide a platform you can depend on. As always, let us know if you have any questions.

Posted Feb 24, 2021 - 21:41 UTC

Resolved
We encountered infrastructure problems which are now solved.
Posted Feb 24, 2021 - 15:42 UTC
This incident affected: Trinsic Credentials API, Trinsic Provider API, and Trinsic Wallet API.